MXNB issuances and MXN Redemptions temporarily unavailable

Incident Report for Juno

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 14:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 13:35 UTC

Investigating

We are currently experiencing issues on MXNB and MXN. Due to this, MXNB issuances and MXN redemptions are temporarily unavailable.
Our engineering team is working to identify the root cause and restore normal processing as quickly as possible.

We apologize for any inconvenience this may cause.
Posted Apr 29, 2026 - 13:25 UTC
This incident affected: Issuances (MXNB Spei, MXNB Bitso Transfer) and Redemptions (MXN Spei, MXN Bitso Transfer).