Investigating Intermittent Delays in Transaction Processing

Incident Report for Juno

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 12:00 UTC

Update

Our engineering team continues to work toward a full resolution of the intermittent delays affecting transaction status updates.

We are monitoring the situation closely and will provide another update as soon as we have more information. Thank you for your continued patience.
Posted Jan 22, 2026 - 15:32 UTC

Identified

We are currently experiencing intermittent technical issues within our issuance process. While you can still initiate transactions, you may notice a delay in status updates (e.g., transactions remaining in "Pending" longer than usual).

Important: Please be assured that funds are not impacted and all transactions are being processed securely.

Our engineering team is working on service restoration. We apologize for the inconvenience and will provide another update shortly.
Posted Jan 21, 2026 - 22:19 UTC
This incident affected: Issuances.