Intermittent issues affecting OTC quote-to-trade conversions.

Incident Report for Juno

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 14:50 UTC

Investigating

We are experiencing intermittent issues affecting OTC quote-to-trade conversions. Some conversions may fail or take longer than usual to complete. Other trading and account activity are unaffected. Our team is actively investigating and working on a fix. We will update this page as we learn more.
Posted Aug 03, 2026 - 16:49 UTC