Cross-chain bridge temporarily paused

Incident Report for Juno

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 23:50 UTC

Identified

We now have a planned resumption window for the MXNB cross-chain bridge: Thursday, April 23, 2026.

Before re-enabling, we are upgrading the bridge's verification layer from 2 to 4 independent verifiers (Canary, Nethermind, Google Cloud, and Deutsche Telekom). Once live, every cross-chain message will require attestations from all four, running on four independent infrastructure providers.

Customer funds have remained safe throughout the pause, and no MXNB balances were impacted. On-chain MXNB transactions within each supported blockchain continue to operate normally — only cross-chain transfers between Ethereum, Arbitrum, Avalanche, Polygon, and Base are affected.

Thank you for your patience.

------------

La ventana de reanudación planificada para el puente cross-chain de MXNB es el jueves 23 de abril de 2026.

Antes de reactivarlo, estamos actualizando la capa de verificación del puente de 2 a 4 verificadores independientes (Canary, Nethermind, Google Cloud y Deutsche Telekom). Una vez activo, cada mensaje cross-chain requerirá las atestaciones de los cuatro, ejecutándose en cuatro proveedores de infraestructura independientes.

Los fondos de los clientes han permanecido seguros durante toda la pausa y ningún saldo de MXNB se vio afectado. Las transacciones de MXNB on-chain dentro de cada blockchain soportada continúan operando con normalidad — solo las transferencias cross-chain entre Ethereum, Arbitrum, Avalanche, Polygon y Base están afectadas.

Gracias por su paciencia.
Posted Apr 21, 2026 - 19:33 UTC

Investigating

Due to an open investigation of a LayerZero bridge implementation unrelated to MXNB, we have temporarily paused MXNB cross-chain transfers across Ethereum, Arbitrum, Avalanche, Polygon, and Base solely as a precautionary measure. This is a planned, reversible action — no issue has been detected, and no funds are at risk.

Your MXNB balances across all chains remain fully accessible, and MXNB over Arbitrum remains available to mint and burn via the Juno Mint Platform. Only chain-to-chain transfers via the bridge are affected during this window.

We will post an update here as soon as the bridge is back online. Thank you for your patience.

------------

Debido a una investigación en curso sobre una implementación del puente LayerZero no relacionada con MXNB, hemos pausado temporalmente las transferencias cross-chain de MXNB en Ethereum, Arbitrum, Avalanche, Polygon y Base únicamente como medida de precaución. Esta es una acción planificada y reversible — no se ha detectado ningún problema y ningún fondo está en riesgo.

Tus saldos de MXNB en todas las cadenas siguen siendo completamente accesibles, y MXNB en Arbitrum continúa disponible para acuñar y quemar a través de la Plataforma Juno Mint. Solo las transferencias chain-to-chain a través del puente se ven afectadas durante este período.

Publicaremos una actualización aquí en cuanto el puente vuelva a estar en línea. Gracias por tu paciencia.
Posted Apr 19, 2026 - 01:08 UTC
This incident affected: MXNB Bridge.