Degradation on USDC | MXNB currency pair | April 17th, 2026

Incident Report for Juno

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 22:55 UTC

Investigating

We are currently investigating an issue affecting the USDC|MXNB currency pair. Some users may experience delays or errors when attempting to trade or convert between these assets.

Our team is actively working to identify the root cause and restore full functionality as quickly as possible.

We will provide an update once new information is available.
--------------------------

Estamos investigando un problema que afecta al par de divisas USDC|MXNB. Algunos usuarios podrían experimentar retrasos o errores al intentar operar o convertir entre estos activos.

Nuestro equipo está trabajando activamente para identificar la causa raíz y restablecer la funcionalidad completa a la brevedad posible.

Proporcionaremos una actualización en cuanto haya nueva información disponible.
Posted Apr 17, 2026 - 22:04 UTC
This incident affected: Conversions (USDC/MXNB).