Ongoing Service Degradation: Cloudflare Global Outage

Incident Report for Juno

Resolved

This incident has been resolved. Cloudflare has confirmed that their services are currently operating normally, with no elevated errors or latency being observed across their network.

Thank you for your understanding and patience during this external outage.
Posted Nov 18, 2025 - 18:07 UTC

Monitoring

Cloudflare implemented a fix and stated that the incident is resolved.

We are seeing signs of recovery across our services, consistent with Cloudflare's update.

Our team is continuing to monitor all internal and external services that were impacted by the global outage.

We expect to see service stability return to normal levels shortly.
Posted Nov 18, 2025 - 15:14 UTC

Investigating

Due to an ongoing, widespread outage impacting Cloudflare's global network, as reported on their official status page: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7 our users might experience service degradation.

Our team is actively monitoring the situation and following Cloudflare's updates.Rest assure that your data and funds remain secure.Thank you for your patience.
Posted Nov 18, 2025 - 14:14 UTC
This incident affected: Juno Website.