Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 04, 2026 - 09:00 UTC
Scheduled
On Wednesday, February 4th, starting at 03:00 MXT and lasting for 2 hours, we will be performing general maintenance to enhance our services.
During this 2-hour window, deposits and withdrawals in Mexican Pesos (MXN), as well as issuances and redemptions of MXNB within the Juno platform, will be unavailable.
We expect all services to resume normal operations immediately following the completion of the maintenance. We apologize for any inconvenience this may cause and appreciate your understanding as we work to improve the reliability and performance of our systems.
Please rest assured that your funds will remain secure at all times.
Posted Jan 22, 2026 - 16:55 UTC
This scheduled maintenance affected: Issuances, Redemptions, Crypto Withdrawals, Crypto Deposits, and Fiat Deposits.